Atari ST: Troubleshooting 


Vorweg gleich ein Hinweis: Das Atarimuseum übernimmt keinerlei Haftung für irgendwelche Schäden oder Verletzungen. Arbeiten an elektronischen Bauteilen sind nur von Leuten mit entsprechendem Fachwissen und entsprechender Vorsicht durchzuführen, insbesondere rund um Netzteile oder in Monitoren herrscht akute Lebensgefahr!

Auch unsere geliebten ST-Computer sind nicht vor Ausfällen und Fehlern geschützt, nachfolgend einmal ein paar Tipps, um den ST wieder zum Laufen zu bewegen.

Erst einmal ein allgemeingütiger Hinweis, der in sehr vielen Fällen schon einmal weiterhilft: Alle gesockelten Chips auf festen Sitz und eventuell vorhandene Korrosion überprüfen. Alle Steckverbindungen prüfen, ebenso die Kontrollleuchten des Systems.

Nachfolgend ein paar speziellere Probleme.

Der Computer „singt“ (betrifft nur 1040 ST)

Ursache dafür ist ein Schwingkreis in der Nähe des ICs TL497, dort in der Nähe liegen der Widerstand R17, die Spule L4 und der Kondensator L28. Der Widerstand muss gegen einen mit 5 Ω getauscht werden, die Spule gegen eine mit 4 µF und der Kondensator gegen einen mit 330 pF. Danach sollte im System wieder Ruhe herrschen.

Auf dem Bildschirm sind schwarze Punkte zu sehen

Hier liegt aller Wahrscheinlichkeit ein RAM-Fehler vor, Baustein U19 ist oft die Ursache. Aber auch die MMU kann dafür verantwortlich sein.

Der Desktop erscheint sofort, aber ohne Icons

Bitte folgendes probieren: Den Rechner ohne eingelegte Diskette starten und warten, bis der Desktop mit den Laufwerks-Icons erscheint. Dann eine Diskette einlegen und versuchen, diese zu formatieren. Ist beides erfolgreich, liegt die Ursache im DMA-Chip, dieser muss dann getauscht werden. Sollte es nicht klappen, liegt der Fehler im Floppycontroller 1772 (zuständig für READ DATA, INDEX, WRITE PROTECT und TRACK 00) und/oder dessen Treiberbaustein 74LS06 (zuständig für WRITE DATA, STEP, DIRECTION, MOTOR ON und WRITE GATE). Sollten Laufwerke nicht richtig selektiert werden, ist aber der Soundchip (zuständig für die Signale DRIVE 1 SELECT, DRIVE 0 SELECT und SIDE 0 SELECT) schuld. Man sieht hier schon, dass die Systemarchitektur ein wenig komplexer ist, als es System und ein Blick aufs Mainboard vermuten lassen.

Drucker druckt nicht

Abgesehen davon, dass man mal schaut, ob der Drucker eingeschaltet und mit dem ST verbunden ist, ist hier oftmals ein defekter Soundchip die Ursache.

Bild läuft durch und Diskettenlaufwerk wird nicht angesprochen (betrifft 260 ST und 520 ST)

Baustein U35 defekt

Bildschirm ist im Farbmodus komplett mit Rot, Grün oder Blau gefüllt (betrifft 260 ST und 520 ST)

Buchse J9 muss überprüft werden.

Weiße Punkte auf dem Bildschirm (betrifft Mega ST)

Hier liegt oft ein thermischer Fehler an den Bausteinen 74LS244 und 74LS373 vor oder das RAM sitzt nicht richtig im Sockel.

Auf dem SM124-Monitor sind Rücklaufstreifen zu sehen

Der Widerstand R727 ist zu hochohmig und muss gegen einen mit 560 kΩ getauscht werden. Danach muss eine kleine Korrektur der Grundhelligkeit am Poti VR702 vorgenommen werden.

Das Bild auf dem SM124 ist nur halb hoch, aber wirkt wesentlich breiter

Hier stimmt etwas mit der Stromversorgung +12V nicht. Bitte IC901 und Q901 überprüfen und ggf. tauschen. Danach +12V erneut durchmessen, die Toleranz sollte hierbei ± 15 % nicht überschreiten.